
Technical FAQs 

  

 
I want to add some new devices to CircuitLogix. These include some transistors as well as a 
few digital devices. How do I do this?  
Analog devices such as Op amps, transistors, FETs and diodes can be added by importing a SPICE 
model file. These files can often be obtained directly from the manufacturer of the devices.. The 
process for importing these models is described in detail in the CircuitLogix user manual. 
Another way to add devices is through use of CircuitLogix's macro capability. With this method, the 
user constructs a circuit that is equivalent to the needed device using devices already available from 
within CircuitLogix. Since this method utilizes CircuitLogix's existing devices, it works well for creating 
both analog and digital devices. Once the equivalent circuit is working it is saved as a macro and 
then available for future use. The macro can have either a standard package type such as a 14 pin 
DIP or a custom shape that the user creates. This process is described fully in the CircuitLogix user 
manual. 
 
 

 
How do I display multiple waveforms on a graph?  
Waveforms are placed on the analysis graphs by clicking on the circuit with the Probe Tool. Each 
time you click on a new point in the circuit, the previous waveform is removed and a new one is 
displayed. If you hold down the SHIFT key when you click on the circuit, the existing waveforms will 
not be removed when the new one is added. If you SHIFT-click on a point in the circuit where a 
waveform is already displayed, that waveform will be removed from the graph. 
 
 
 
 
 

 
Why doesn't my circuit work the way it should?  
The most common problems deal with syntax: 

• SPICE recognizes most standard engineering notation multipliers, but is not case sensitive: 
T = 1E+12 
G = 1E+9  
Meg = 1E+6 
 
K = 1E+3 
f = 1E-15 
p = 1E-12 
 
n = 1E-9  
u = 1E-6  
m = 1E-3 
 

• There can be no space between the value and the multiplier. For example, "1.00 uF" is 
considered to be 1 Farad.  

• Do not confuse Farads with fempto EX. "1.0 F" on a capacitor means 1 Farad while "1.0F" 



means 1 fempto Farad (1E-15).  

• Do not confuse milli with meg. In SPICE, the "m" or "M" multiplier means milli (1E-3). "Meg" 
is the proper multiplier meaning 1E+6. For example, 1MHz in SPICE means 1 millihertz. 

 

 
Some of the wires in my schematic don't have dots to show that they are connected. What's 
going on?  
You have connected multiple wires to a single device pin and disabled the "Show Pin Dots" option in 
the View menu. If you want to see where one wire is connected to another, you must actually 
connect to the wire, not to a pin. 
 
 

 
Why do I get SPICE errors when I place a Transformer in my circuit?  
Every node in a circuit must have a DC path to ground. Transformer isolates one section of the 
circuit from the rest of the circuit. Therefore, you must ensure that there is still a DC path to ground 
for both sections of the circuit. This can be done in various ways: 

• Place a ground device directly on both sides of the transformer.  

• Connect a high value resistor in parallel with the transformer.  

• Connect a high value resistor to ground on the floating side of the transformer.  

• Use the RSHUNT option in the Analog Options dialog box to place a high value resistor 
between all circuit nodes and ground. 

 

 
Why won't my oscillator, 555 timer or astable circuit oscillate?  
In some circuits, such as oscillators and those with feedback, initial conditions may be required on 
some nodes or devices. Try adding an initial condition (.IC) device to the output(s) of the circuit to 
help the SPICE simulator know where to start. If there are diodes in the circuit, set their initial 
condition to "OFF". Try increasing ITL4 to 100 and TRTOL to 3 in the Analog Options dialog box in 
the Options menu. 
 
 

 
When I try to run analog simulation, I get various SPICE errors, such as "timestep too small", 
"Gmin stepping failed", "singular matrix error", etc. What do I do?  
SPICE errors can result for any number of reasons. In general, they indicate a problem with realistic 
modeling of the circuit. For a more complete analysis of SPICE errors, see Appendix A of the 
CircuitLogix User Manual. 
 
 

 
Why doesn't my op-amp circuit work after I have rotated and mirrored the op-amp?  
When you rotate and mirror a device, all of the pins are also rotated and mirrored. You must be 



careful not to connect the power supply pins in reverse. In CircuitLogix, when the + input of an op-
amp is on the bottom, the + supply is on the top. Some alternate op-amp symbols have been 
included in CircuitLogix in which the input pins have been reversed. 
 
 

 
Why doesn't the multimeter read the expected value?  
This could be caused by a couple of things: 

• The multimeter averages the data from the Transient Analysis to obtain a result (just like a 
real multimeter). If the Transient Analysis start/stop time is too short, there will not be enough 
data to make an accurate measurement.  

• If the RSHUNTS has been enabled and the shunt resistors values are too small, they will 
have an obvious affect on the current flow through the circuit. RSHUNTS places a large 
value hidden resistor between each node and ground to simulate leakage resistance. 
RSHUNTS is found in the Analog Options dialog box in the Options menu. 

 

 
Why is the polarity of the current wrong when measured on some devices?  
In SPICE, current, which flows from the device's terminal 1, through the device, and out its terminal 
2, is considered to be positive current. For this reason, a positive voltage source will always read 
negative current. If a resistor is placed in the circuit such that pin 1 is at a more negative potential 
than pin 2, the current measured on that resistor will be negative. 
 
 

 
I want to set up 3 Signal Generators to simulate a 3-phase AC source. Even though I set the 
Phase field on the three generators to 0, 120 and 240 degrees, all three generators produce 
exactly the same waveform in Transient Analysis with no phase shift. What's wrong?  
The Phase field is for AC Analysis only, not Transient Analysis. In order to produce the results you 
are looking for, you must change the Start Delay for each of the three generators. For a 60Hz sine 
wave, set the Start Delays on the three generators to 0.0s, -5.56ms and -11.11ms. 
 
 

 
How come I don't see the simulation when I click the ON/OFF button?  
This could be caused by various problems: 

• You may be trying to run an Analog simulation with Digital simulation mode selected. To run 
an Analog simulation, Analog mode must be enabled in the Simulation menu.  

• If you have added a SPICE subcircuit to the library and are trying to use the new device in 
your circuit, you may have a problem with the number of pins on the device. The number 
(and order) of pin nodes listed in the Spice Data field for the device (double-click on the 
device, then click on the Netlist... button) must match the number (and order) of pin nodes 
listed in the subcircuit (on the SUBCKT line). 

 

 



My circuit application requires that I place two or more power sources and/or inductors in 
parallel, but when I do so, SPICE generates an error. What do I do?  
In SPICE, power sources and inductors are perfect, that is, there is no internal resistance. If you 
must place these in parallel, then you must include a low value resistance in series with each of 
these devices to accurately simulate real-world conditions. 
 
 

 
My circuit application requires that one section of the circuit be isolated by capacitors, but 
when I do so, SPICE generates an error. What do I do?  
In SPICE, capacitors are perfect, that is, there is no internal leakage resistance. If capacitors are 
placed in series, or if they isolate a section of your circuit, then you must place a large value 
resistance in parallel with each capacitor to accurately simulate real-world conditions. 
 
 

 
Why does SPICE give an "unknown parameter" error?  
This occurs when SPICE sees something that it doesn't recognize. For example: 

• There may be a typographical error in a model or subcircuit that is being used.  

• Some models or subcircuits are created specifically for use with another vendor's simulator 
that may not be 100% SPICE compatible. For example, some device parameters in PSpice 
have been altered from the original SPICE2 and are not recognized by SPICE3. 

 

 
Why do I get SPICE errors when I use a Relay in my circuit?  
Relay contact pins are active in a circuit simulation and must be connected. If one or more contact 
pins are not used in your circuit do one of the following to avoid SPICE errors: 

• Connect a high value resistor between each unused (floating) contact pin and ground.  

• Use the RSHUNTS option in the Analog Options dialog box to place an invisible high value 
resistor between all circuit nodes and ground. 

 

 
SPICE gave me a SINGULAR MATRIX error on node c1_2. What is a SINGULAR MATRIX and 
where is node c1_2?  
SINGLUAR MATRIX generally refers to a component that is not connected (see appendix A) . Node 
names can be displayed using the SHOW NODE NUMBER item in Options > Schematic. The node 
name c1_2 is derived from pin2 of device C1. 
 
 

 
Can I use CircuitLogix to build and test circuits which include vacuum tubes? Also, can I 
enter data into CircuitLogix in order to add additional tubes.  
We currently have a few vacuum tubes in CircuitLogix, namely the 5879, 6L6GC, 7199P, 12AU7, 
12AX7, 6SN7 and 7199T. Yes, it is possible to add more, but this is not a trivial task and you would 



need to be very familiar with Spice in order to do it successfully. 
 
 

 
When I simulate an amplifier circuit driven by a signal generator with a DC offset the transient 
analysis waveforms are correct but the AC analysis waveform is not. Why?  
AC analysis uses the signal generator as a source for its gain calculations. Therefore, the DC offset 
in the signal generator is considered when circuit gain is calculated. To avoid this problem, the DC 
offset required should be supplied from a voltage source in series with the signal generator and the 
signal generator should not have any offsets. 
 
 

 
How do I adjust the value of a variable resistor?  
A variable resistor is adjusted by setting a percentage value in the device's Label-Value field. For 
example, to set a variable 10k resistor to its halfway point, enter "10k 50%" into the Label-Value field.
 
 

 
How do I change my component's pin name and shift its position? In addition, how can I 
place a bar or NOT sign over a pin name  
The pin names of devices provided in CircuitLogix's User.Lib cannot be modified, either in content or 
position. However, all pins on a macro (a component you've designed yourself) can be named and 
arranged upon its creation. Regarding placement, you may choose to have the pin name placed in 
parallel with or perpendicularly to the pin. There is no way to reposition the pin beyond these two 
options. You can create barred pin names by entering braces { } around all or part of a pin name. 
Barred pin names work correctly only with monospaced fonts, such as Courier New, CircuitLogix's 
default font. If you are trying to modify an existing macro, place the macro on a blank schematic 
page, click once on it to select it, then expand it by pressing Control + E or clicking on Macro > 
Expand Macro. Then select the symbol again, and choose Macro > Edit Macro. Click on Symbol, 
which invokes the Symbol Editor dialog box. Now you may make changes to the pins, either by 
double-clicking on the individual pins in the main view screen on the right, or by cutting, modifying, 
and appending the lines of code in the Element List on the left.  
 
 

 
Why can't I resize my waveforms in digital mode?  
In digital mode, you may resize the waves horizontally, but not vertically. When running a digital 
simulation, under the Digital tab of the Panel, use the X Magnification field to vary the length of the 
waveforms. There is no way, however, to change the amplitude between high and low signals.  
 
 

 
When I generate a netlist from my schematic, I get the error: "The selected items in this 
circuit do not indicate a PACKAGE type." Why is this?  
Each schematic symbol that represents a physical component on the PCB you're designing must 
have a corresponding Package name for the PCB program to use. (Other programs may refer to this 
as a Footprint or a Pattern.) The Package field is in the Device Properties dialog box (right-click on 



any component and choose Device Properties...). Enter the name of any part you already have in 
your PCB libraries, or the name of a part you plan to create later. If a selected item is one you do not 
wish to represent a physical component, you may ignore this message, and in the future, check 
Exclude from PCB at the bottom of the Device Properties dialog box for such components. NB. If any 
components on the schematic are selected before you create the netlist, these will remain selected 
when this error is generated. These may already have information in the Package field. If so, simply 
ignore them as far as this error is concerned.  
 
 

 
Why does my circuit stop simulating when I rename my ground nodes?  
CircuitLogix allows you to rename your ground pins by double-clicking on them, and changing the 
name in the Bus Data field (the default is GND). However, CircuitLogix's simulation engine requires 
at least one ground node with the bus data: GND; to be present somewhere on the schematic page. 
Its placement is irrelevant; in fact, it does not need to be attached to any part of the circuit.  
 
 

 
How do I auto-wire two points?  
In wiring mode, you can click and drag from one pin to another. This will allow CircuitLogix to plot its 
own orthogonal pathway between the pins. You may also drag between two wires, or a pin and a 
wire. The alternative to this is a series of single-clicks delineating each corner of the wiring scheme. 
 
 

 
How come I don't see the simulation when I click on the ON/OFF button?*  
Make sure the correct split screen view option is chosen, then click the probe (analog mode) or place 
a scope (digital mode) on any node in the circuit. If you want to view multiple nodes in analog mode, 
you can hold down the Shift key while you click the probe on each node. In digital mode, you can 
place any number of scopes in the circuit (hotkey T).  
 
 

 
Can I change the colors in my simulation window?  
Yes. When running a simulation, right-click in the waveform area, choose Preferences, then double-
click on any one of the colored fields to modify it. You may place a check in the lowest left corner of 
this dialog box to indicate that these new colors should overwrite your default colors. If, on the other 
hand, you like the computer display, but need to export or print graphs with a white background, 
there are choices to that effect in this same Wave Preferences dialog box.  
 
 

 
I keep having to enable a high RSHUNT value in my circuits. Is there a way to change the 
default from zero to a high value? 
Or: Is there a way to modify the Analysis Setup defaults?  
Analysis settings are saved with your circuit, but there is currently no way to modify the original 
defaults. For example, each time you open a new CircuitLogix document, its default value of 
RSHUNT is always zero, and if you want that to be another number, it is a somewhat tedious 



process to invoke each time you start a new document. Some of our users have found ways to 
record keystroke sequences within CircuitLogix via other third-party recording programs.  
 
 

 
When I open my program, I receive the following error: "Unable to locate the specified font: 
TrueType: Courier New Exit CircuitLogix and install this font or select PREFERENCES under 
FILE and choose one in the font list." Why is this?  
TrueType Courier New is the font that CircuitLogix will try to use if no other default has been 
specified. You may install this font in Windows' Control Panel, or you may change your default font in 
CircuitLogix. To do the latter, choose Options then Schematic to invoke the Schematic Options 
dialog box (hotkey F5). Under the General tab, choose from the drop-down list beneath Device Font. 
Make sure you check the option at the base of this dialog box, entitled: "Save current settings as 
defaults." If only a short list of available fonts appears, you should reboot your computer and see if 
the full list returns.  
 
 
 
 
 

 
Why won't my circuit simulate?  
You must have a ground node (hotkey 0) with the default Bus Data (GND;) present on the schematic 
for any analog simulation to run.  
 
 

 
Why can't I simulate Microprocessors with CircuitLogix?  
Microprocessors run through multiple states, and SPICE is designed for single-state simulation. If 
you have separate SPICE models for each state, you can make a macro for each one and achieve 
simulation results that way.  
 
 

 
I received the installation CD for CircuitLogix, but when I put it in my CD-ROM drive, nothing 
happens. How do I install the program?  
When you insert the CircuitLogix CD the installation Wizard will start automatically after a brief pause 
(if auto start is not disabled). If it does not, select Run from the Start menu. In the Run dialog box, 
enter the following: 

D:\Setup.exe where D: is your CD  
The installation wizard will appear. Follow the instructions to install the software. You will be 
prompted to enter the Access Code for CircuitLogix during the installation.  
 
 

 
How do I panelize my boards?  
You can panelize in two ways. You can save your board file, then choose File > Merge, and open the 



same file that you are in. Now you will have a copy of the board hovering on the mouse, which you 
can place anywhere with a single left click. This method is useful if you need only two or three copies 
of the board in a single PCB file.  
The second method is to duplicate the board, which is more useful if you need several copies of the 
board in one PCB file. To do this, select the board, either by dragging the mouse across it, pressing 
Control + A, or clicking on Edit > Select > All. Then open the Duplicate dialog box by pressing 
Control + D or choosing Edit > Duplicate. If you want each panelized board to be an exact replica of 
the original, ensure that both options "Duplicate All Layers" and "Use Same Designators" are 
checked. Specify the Count (number of duplicates) and either the X or Y offset, and click OK.  
NB. If you want to make a panelized grid from a single board, you need to follow these steps twice-
the first time to duplicate the single board along one axis, and the second time to duplicate the row or 
column along the other axis.  
 
 

 
How do I draw a dotted line in CircuitLogix?  
Hold down the 'Alt' key while drawing the wire. Note: This wire is fully functional, and will carry a 
current if it is connected to live nodes.  
 
 
 
 
 

 
When I try to double-click on a component in PCB layout, the Edit box does not always 
appear. Instead, my cursor jumps to pin 1 of the component. Why is this?  
You are simply holding the mouse button down too long as you click upon the component. Notice 
that clicking and holding the mouse on any component will put you in Moving mode, ready to drag 
the component elsewhere on the board. The mouse snaps to pin 1 to help place the component at its 
new location with precision.  
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